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Session 04 – KEYBOARD INPUT

ANGLE MODES
Standard, Compass (NSEW).
There are two angle modes available within AutoSketch, STANDARD and COMPASS, and
these can be selected from within the Tools>Drawing Options commands.

However rather than changing the modes all the time I suggest that the mode be left on
Standard (Default).  And, when a compass direction is needed use N, S, E, W Etc…

Standard mode 0° is to the Right and Anti Clockwise where as COMPASS is 0° Vertical and
angles are in a Clockwise direction.

90°

0°180°

270°

225°

45°

STANDARD

0°(N)

90°(E)

180°(S)

270°(W)

(NW) (NE)

(SE)(SW)

COMPASS

Standard and Compass
modes are selected from
the Drawing Options dialog.

Select Orientation and
either Standard or
Compass.

I usually set Angle to Deg-
Min-Sec with a Precision of
0.0001.

As we will learn later (if I
remember to write it) there
are many ways of entering
angle notation, so the
settings selected here are
the units that the system
uses in its dialog boxes.
You can change these at
any time without any
disasters happening.
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Relative [R]

Relative is a keyboard input mode to select
points on the drawing relative to the last
selected point chosen.  Relative mode can be
used in either XY where two distances are
used, similar to map references, plus POLAR
which uses a distance and a direction with the
direction being influenced by the angle
modes, Standard and Compass.

The XY and POLAR modes are selected from
the second row of buttons in the dialog, and
selecting either of these will change the input
boxes.

The mode can be changed at any time without
effecting the last point that is the relative
reference.

The biggest mistake people make is realising that this mode is RELATIVE to the LAST POINT
selected, and quite often forget to establish a start point prior to selecting Relative Snap [R].
Therefore generally selecting an existing position or a random start point with Snap Off will
precede relative mode.  Once a start point is selected press R, and the Dialog will highlight in
the centre of the screen, which you
can move to another location if
desired by dragging its title bar with
the mouse.  Whilst using this
method of selecting points, the
mouse can be given a spell (and a
piece of cheese) as all input will be
vial the keyboard.

POLAR
Once a relative point has been established and [R] has been keyed in, Polar mode needs to
be set, this is the second button on the second row.
• The DISTANCE is typed into the TOP box R.
• Press TAB to move down
• Insert the DIRECTION in the LOWER box Ø.
• Press ENTER, then repeat this process for continuous lines.  The highlight will have

moved back to R.

Generally this command will be used with the Draw Line Multiple or Double where continuous
lines are needed.

The distances are easiest entered as Alpha compass bearings EG:
[E] East = 0°
[N] North = 90°
[W] West = 180°
[S] South = 270°

[NE] North East = 45°
[NW] North West = 135°
[SW] South West = 225°
[SE] South East = 315°



On the Right on the Edit Boxes is a tick box stating Relative, for everything we do this should
be left blank.  The purpose of this option is to make the last line drawn be an assumed relative
bearing of 0°, therefore the next angle Ø will be relative to this line rather than the customary
0° to the right.

LINE DOUBLE
This command draws continuous parallel lines.
The user specifies the distance between the
lines and the Offset method also needs to be
selected.

The WIDTH between the lines is placed into the
right hand edit box that appears in the edit bar, and
remember to press [ENTER] to record your entry.

The OFFSET METHOD is selected from the drop
down on the left.  Choose from Left, Center or Right.
These three options refer to the points selected by
the user, so if CENTER is chosen the two lines will
be spaced evenly either side of the selected points.  If LEFT is chosen a line will be inserted
where you are selecting and the second line will be placed to the right, YOU are drawing on
the LEFT.

Therefore if we are drawing around the perimeter of a house in a clockwise direction, we will
be selecting distances for the left line a second line will be required to the right.  So we would
choose LEFT as this will be the side that receives the known distances.
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EXERCISE 04a - Draw External Walls - Polar

   Open a New Drawing from either the New Drawing Icon or the File>New menu or
even [Ctrl + N].

• Set Units to mm with no precision 1. And do not display Units
• Set Orientation to Deg Min Sec with precision of .0001
• Set the Scale to 1:100

To draw the external walls for the house the Draw>Line Double will be used, this command
draws a series of single trimmed lines with a second line placed alongside.

  

Routine for drawing around the perimeter of a House:

• [S] Snap Off
• Draw>Line Double
• Edit Bar - select Left and 250mm.
• Select a start point (bottom left).
• [R] Relative - Polar
• Insert the first Distance (5150)
• [TAB]
• Direction, use compass directions NSEW Etc.… (N)
• [Enter]
• Second Distance (2715)
• [TAB]
• Second Direction (NE)
• [Enter]
• ETC until complete.

OBJECTIVE 04a
To draw double lines representing the external walls of a house.

COMMANDS
Line Double – Relative (Polar).

METHOD
After selecting a start point with the double line command, use [R]elative Polar
to draw clockwise around the house perimeter.

OUTCOME
We will have drawn the around the perimeter of the house accurately which
forms the basis for the remainder of the house.
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HOUSE PLAN TO BE DRAWN
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Draw walls in a 
clockwise direction
starting at any point

The above command can be used to check if your drawing finishes exactly where it started by
choosing Endpoints from the start of the first and end of the last lines
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X Y
XY input is similar to Polar with the difference being that two distances are inserted rather than
a distance and direction.  The two distances are firstly Horizontal ‘X’ and then Vertical ‘Y’ and
in turn these give a distance and from the relative point and the co-ordinate XY.  From the
relative we move the X distance (Horizontal) and then from this point the Y distance (Vertical).

X to the left is a negative distance and Y down is also a negative distance.

+X

+X+Y

+Y

-X

-Y

+X-Y-X-Y

-X+Y

RELATIVE XY

30°0'0"

Distance X

Distance Y

Therefore drawing a line to the bottom right
would have a positive X value and a negative -
Y value

This command is very
useful when drawing
lines at an angle when
only Horizontal and
Vertical distances are

known, as is the case generally with external walls, where all
dimensions are given only as Horizontal and Vertical so as to
accomplish correct brick dimensioning.

Also when drawing Rectangles using Poly Rectangle the XY method
can be used for the Horizontal distance (X) and the Vertical distance
(Y).
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EXERCISE 04b - Draw External Walls - XY

Draw the following house again, this time using only X & Y dimensions.

Routine for drawing around the perimeter of a House:

• [S] Snap Off
• Draw>Line Double
• Edit Bar - select Left and 250mm.
• Select a start point (bottom left).
• [R] Relative - XY
• Insert the X Distance (0)
• [TAB]
• Insert the Y Distance (5150)
• [Enter]
• Second X Distance (1920)
• [TAB]
• Second Y Distance (1920)
• [Enter]
• ETC until complete…

The above command can be used to check if your drawing finishes exactly where it started by
choosing Endpoints from the first and last lines

OBJECTIVE 04b
To draw double lines representing the external walls of a house.

COMMANDS
Line Double – Relative (XY).

METHOD
After selecting a start point with the double line command, use [R]elative XY to
draw clockwise around the house perimeter.

OUTCOME
We will have drawn the around the perimeter of the house accurately which
forms the basis for the remainder of the house.
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JUMP [J]

Jump Snap is a snap mode that most people have
been waiting for since earlier versions, it is very
simple, your selection point will jump along an
entity (Line) a set distance from an end point.

For determining the Distance there are two Jump
options, DISTANCE and PERCENTAGE.  Distance
is set in the units of measurement and
PERCENTAGE is the portion of the line segment as
the distance.  Generally we use distance, but to give
an idea 50% in percentage would be identical to
Midpoint Snap [M].

EXERCISE 04c – Position windows

 Open EX04C.SKF

Insert window symbols from the symbol library
into the walls.  The symbols can be rotated
with the [+] & [-] keys on the number pad on
the right.  Set the JUMP distance to any size
and see if you can break it.

If you place a window in the
wall from the right, you will also
need to add the width of the
window to the Jump dimension,
and this can be achieved with
[=].  The use of the = sign
allows calculations to entered
into edit boxes EG. =1210+960.
Remember to use [Enter] after
inserting the data.

OBJECTIVE 04c
To position a symbol of a window on a External wall.

COMMANDS
Symbol Point – Jump Snap

METHOD
Select a symbol and use jump snap to position the symbol.

OUTCOME
The window symbols in plan will be correctly located ready for trimming.
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Bull Nose Verandah
We will now drag a line and an arc to complete an
elevation of  a Bull Nose Verandah on an octagon.

Using Handles and [CTRL] stretch the line and arc to
produce the drawing as shown.

1) Select the entities.

2) Select [E] End Point Snap

3) Drag to the right, holding
the [CTRL]

4) Drag the left hand side
across as shown, without
using [CTRL]

5) Two sets of entities now
exist but are different
shapes.

6) Select both sets of entities

7) Drag from the left hand side Across to the right, once again holding [CTRL]

8) Drag the existing selection as shown to finish the drawing.
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9) The entities have now been mirrored using the mouse.

UNCONSTRAIN

Sometimes it is an advantage to drag the selection handles out of proportion and this can be
achieved with the use of the [Shift] key. In the following exercise we will drag the top right
selection handle of the Stairs down into position whilst holding the [Shift] key.

1. Select End [E] snap.
2. Select the top right selection handle
3. Hold the left mouse button and the [Shift] key then drag into position.
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EXERCISE 08b - Draw Door Frames

   Open a New Drawing from either the New Drawing
Icon or the File>New menu or even [Ctrl + N].

1. Set your scale to 1:10 and units as millimetres.

2. Draw a horizontal line, select it then change its length in
the Edit Bar to 1570 long.

3. Insert a 50x100 Rectangle on the left-hand side, use [E]
End point then [R] Relative and XY to insert the sides.

 
 
4. From the midpoint on the rectangle [M] draw two lines,

one horizontal [X] to the midpoint [M] of the base line,
and the other from the End [E] of the previous line
vertical [Y] to approximately where the swing will end
[S].

 
5. Use 2 Points and Center Arc to draw the door swing with

[E], using Ctrl to swap the centre point.

6. Trim the circle to the line with Trim Corner

7. Offsetting a second line with a 30mm distance to
indicate the door.

 
8. Select only the door frame and swing lines.

9. Using Transform>Mirror, remembering to check ‘Leave
Original’, mirror your selection by selecting the end [E]
of the swing then another point vertical to this point [Y]
and [S].

1.

2.

3.

4.

5.

6.

7.

8.

1570 LINE

50 X 100 RECT

30mm OFFSET
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TRACING A SCANNED IMAGE
Drawing over a scanned BMP file can sometimes speed up the drawing process, but bringing
a scanned image into a drawing can be tricky for the new players at this game.  The problem
is that BMP (Bitmap) files are not to scale, so we will need to resize them.

To place the picture onto your drawing select the Picture
From File button from the CAD Tool Bar.  This will open the
Edit Bar and also place a message at the bottom left of the
screen.

The button to the Right of the Image File box will open the Bitmap Dialog and here you can
find and select an Image.

The Image can then be inserted onto
the drawing.  Holding the [Shift] key
whilst placing the image will ensure that
it is in proportion.

Scans can be placed onto layers and
their layer state changed as per normal
entities.

The following Exercise will demonstrate
how to resize the image.

EXERCISE 18b – Insert Scan Image (Bitmap)

  Open EX_18B.SKF

Open the Drawing, there is already a rectangle drawn to size to represent a portion of the
scanned image.  We will fit the scan to this rectangle and once complete the rectangle can be
removed.

OBJECTIVE
Insert a BMP file onto the drawing and resize it to scale

COMMANDS
Picture From File – Edit(Bar)>Align Picture

METHOD
Place picture, Draw a rectangle to scale, resize the picture to fit the rectangle

OUTCOME
From here the drafter will be able to bring in scanned images and draw over
them as part of their drawing.
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The button to the Right of the Image File box will open the Bitmap Dialog and here you can
find and select an Image.  Hold the [Shift] key and use the mouse to place the image
overlapping the rectangle.

Select the Picture, the edit bar will
show some new buttons and on
the right hand side is an Align
Picture button.

Next using your mouse wit [S]
Snap off, choose point 1 on the
image and then with [E] End point
select point 2 on the rectangle,
then repeat this process for 3 & 4.

Once the image is in position and
to Scale the rectangle can be
removed.

Also there is a button to the left of
the Image file box that will embed
the picture into the drawing so that
it forms part of the FILE.  So by

using this it will enable the file to be copied and moved with out the need to also keep a copy
of the original BMP file.


